NexHealth Status - Partial DentrixAscend Synchronizer Outage – Incident details

All systems operational

Partial DentrixAscend Synchronizer Outage

Resolved
Degraded performance
Started 7 months agoLasted about 4 hours

Affected

Synchronizer

Updates
  • Resolved
    Resolved
    The deployed fix has been deployed for a majority of customers and continues to rise.
  • Monitoring
    Monitoring
    A fix has been merged for the underlying issue, we are monitoring its deployment status as well as the efficacy of the fix.
  • Identified
    Identified

    We've encountered an issue with our Dentrix Ascend Synchronizer, affecting forms and appointments booked online syncing into Dentrix Ascend