NexHealth Status - Dentrix Data Synchronization Outage – Incident details
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Get updates
All systems operational
Dentrix Data Synchronization Outage
Resolved
Partial outage
Started 12 days ago
Lasted about 6 hours
Affected
Synchronizer
Partial outage from 5:00 PM to 10:41 PM
Dentrix
Partial outage from 5:00 PM to 10:41 PM
Updates
Resolved
July 07, 2025 at 10:41 PM
Resolved
July 07, 2025 at 10:41 PM
This incident has been resolved.
Monitoring
July 07, 2025 at 5:00 PM
Monitoring
July 07, 2025 at 5:00 PM
We implemented a fix and are currently monitoring the result.