NexHealth Status - Microsoft 365/Outlook email addresses cannot reliably accept emails – Incident details

All systems operational

Microsoft 365/Outlook email addresses cannot reliably accept emails

Resolved
Partial outage
Started 12 days agoLasted about 19 hours

Affected

Patient Communications

Partial outage from 8:30 PM to 3:00 PM

Email

Partial outage from 8:30 PM to 3:00 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Microsoft is no longer reporting any issues with email deliverability.

  • Update
    Update

    Email delivery is improving, but Microsoft is still working to fully resolve the issue. We are waiting on further updates from them.

  • Monitoring
    Monitoring

    We have identified the cause as Microsoft experiencing a partial outage that is degrading our ability to send emails to Microsoft 365/Outlook accounts. We are monitoring the situation and working to identify workarounds.

  • Investigating
    Investigating

    We are investigating to identify the cause.