Denticon has resolved the issue preventing third-party updates to patient profiles. Systems are now operational.
Monitoring
Monitoring
The issue has been identified as an unexpected third-party change. Denticon is actively working on resolving the issue. We are monitoring the situation.
Investigating
Investigating
We have detected a partial outage with the Denticon Synchronizer and are investigating the cause.