NexHealth Status - Investigating Dentrix Form Insert issues – Incident details

All systems operational

Investigating Dentrix Form Insert issues

Resolved
Operational
Started 3 months agoLasted about 1 hour

Affected

Synchronizer

Operational from 5:43 PM to 6:43 PM

Dentrix

Operational from 5:43 PM to 6:43 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    We are aware of form insert issues with [Dentrix] and are actively investigating.