NexHealth Status - Investigating Dentrix Synchronizer delay issues – Incident details

All systems operational

Investigating Dentrix Synchronizer delay issues

Resolved
Degraded performance
Started 12 days agoLasted about 4 hours

Affected

Synchronizer

Degraded performance from 11:54 AM to 3:34 PM

Dentrix

Degraded performance from 11:54 AM to 3:34 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are aware of delay issues with the Dentrix Synchronizer affecting some customers and are actively investigating.